Multiple Printer Redirection Instances
Description:
When using terminal services with redirection of printers with RPV report and the user chooses the redirected-printer from the drop-down list, they may see multiple instances of the redirected printer. The redirected printer may show "redirected 1", and another "redirected 2", etc.
Each printer-instance appears in this user's drop-down list once for each RTA-user currently logged on. This is an RPV bug in the version 5.4 files of RPV.
Cause:
When Client.exe is re-run on the terminal server, RPV.exe and pvCorporate.OCX files are re-installed. Those version 5.4 files contain a bug causing multiple instances of printers to appear in the RPV printer dropdown list. The version 5.3 files do not contain the bug.
Solution:
Replace two version 5.4 files with version 5.3 files:
- Logon to the terminal server of the client
- Open folder C:\Program Files(x86)\RPV
- Check Properties>Details version of RPV.EXE and RpvCorporate.ocx is version 5.4
- Download customers.rtafleet.com/files/RpvRedirectionFix.zip to C:\Program Files(x86)\RPV
- Unzip and replace files RPV.EXE and RpvCorporate.ocx
- User CTRL-ALT-END logoff of their current RDP connection.
- User RDP-reconnect terminal services to RTA
Verify:
There should now be only one redirected instance for each printer listed
in their RPV printer drop-down list.