/
Multiple Printer Redirection Instances

Multiple Printer Redirection Instances

Description:

When using terminal services with redirection of printers with RPV report and the user chooses the redirected-printer from the drop-down list, they may see multiple instances of the redirected printer. The redirected printer may show "redirected 1", and another "redirected 2", etc.

Each printer-instance appears in this user's drop-down list once for each RTA-user currently logged on. This is an RPV bug in the version 5.4 files of RPV.

Cause:

When Client.exe is re-run on the terminal server, RPV.exe and pvCorporate.OCX files are re-installed. Those version 5.4 files contain a bug causing multiple instances of printers to appear in the RPV printer dropdown list. The version 5.3 files do not contain the bug.

Solution:

Replace two version 5.4 files with version 5.3 files:

  1. Logon to the terminal server of the client
  2. Open folder C:\Program Files(x86)\RPV
  3. Check Properties>Details version of RPV.EXE and RpvCorporate.ocx is version 5.4
  4. Download customers.rtafleet.com/files/RpvRedirectionFix.zip to C:\Program Files(x86)\RPV
  5. Unzip and replace files RPV.EXE and RpvCorporate.ocx
  6. User CTRL-ALT-END logoff of their current RDP connection.
  7. User RDP-reconnect terminal services to RTA

Verify:

There should now be only one redirected instance for each printer listed

in their RPV printer drop-down list.

Related content

RPV.INI could not be opened or doesn't exist
RPV.INI could not be opened or doesn't exist
More like this
RPV Error - NovaPDF product not licensed
RPV Error - NovaPDF product not licensed
More like this
RPV Runtime Error 75
RPV Runtime Error 75
More like this
RPV Emailer not Working
RPV Emailer not Working
More like this
Printers
More like this
Mechanic Workstations
Mechanic Workstations
More like this